
12-18
Software Configuration Guide—Release 15.0(2)SG
OL-23818-01
Chapter 12 Configuring the Catalyst 4500 Series Switch with Cisco Network Assistant
Configuring Network Assistant in Community or Cluster Mode
This example shows how to configure Network Assistant on a networked switch in cluster mode:
Switch# configure terminal
Switch(config)# vtp domain cnadoc
Switch(config)# cluster run
Switch(config)# cluster enable cnadoc
Switch(config)# vlan 10
Switch(config-vlan)# interface GigabitEthernet 2/1
Switch(config-if)# switchport access vlan 10
Switch(config-if)# interface vlan10
Switch(config-if)# ip address aa.bb.cc.dd
Switch(config-if)# no shut
Switch(config-if)# ip http server
Switch(config-if)# ip http secure-server
Switch(config)# ip route 0.0.0.0 0.0.0.0 123.123.123.2
Step 7
Switch(config-vlan)# interface {vlan vlan_ID |
{fastethernet | gigabitethernet}
slot/interface
| Port-channel number}
Selects the interface that connects to your CNA-enabled PC.
Step 8
Switch(config-if)# switchport access vlan
vlan_id
Enables the physical port to be in the specified VLAN.
Step 9
Switch(config-if)# interface {vlan vlan_ID |
slot/interface
| Port-channel number}
Select the VLAN instance for configuration.
Step 10
Switch(config-if)# ip address ip_address
Assigns an IP address to the SVI.
Step 11
Switch(config-if)# no shut
Enables the interface.
Step 12
Switch(config-if)# ip http server
Starts the HTTP server so that Network Assistant can talk to
the switch.
Step 13
Switch(config)# ip http secure-server
(Optional) Enables the switch to accept HTTPS connections
from Network Assistant.
Step 14
Switch(config)# ip route a.b.c
Establishes the route to the default router, usually supplied
by the local Internet provider.
Note This line represents the only difference between the
configuration for a standalone and a networked
switch.
Step 15
Switch(config)# line con 0
Selects the console port to perform the configuration.
Step 16
Switch(config-line)# exec-timeout x y
Configures an automatic session logout if no keyboard input or
output is displayed on the terminal.
Step 17
Switch(config-line)# password password
Specifies a password for the console port.
Step 18
Switch(config-line)# login
Allows login to the console port.
Step 19
Switch(config-line)# line vty x y
Creates additional VTY lines for CNA to access the switch.
Step 20
Switch(config-line)# password password
Specifies a password for the switch.
Step 21
Switch(config-line)# login
Allows login to the switch.
Step 22
Switch(config-line)# line vty x y
Creates additional VTY lines for CNA to access the switch.
Step 23
Switch(config-line)# password password
Specifies a password for the switch.
Step 24
Switch(config-line)# login
Allows login to the switch.
Step 25
Switch(config-line)# end
Returns to privileged EXEC mode.
Step 26
Switch# show running-config| include http
Verifies that the HTTP server is enabled.
Command Purpose