Allied Telesis AlliedWare Plus Switch User Manual


 
Page 17 | AlliedWare Plus™ OS: Overview of QoS
Applying ordinary policers to class maps
Ordinary policers are used when policing traffic in a single class map in a single policy map on
a single port. You create them in policy map class configuration mode, which means they are
attached to that policy map and class map at the time they are created. They do not have a
name, because they are identified by the policy map and class map.
The following commands give an example of a single-rate policer that monitors VLAN 2
traffic in the class map called “vlan2” in the policy map called “vlan2” on port
1
.0.20:
awplus(config)#class-map vlan2
awplus(config-cmap)#match vlan 2
awplus(config-cmap)#policy-map vlan2
awplus(config-pmap)#class vlan2
awplus(config-pmap-c)#police single-rate 10000 512 1024 exceed-action drop
awplus(config-pmap-c)#interface port1.0.20
awplus(config-if)#service-policy input vlan2
Applying aggregate policers to class maps
Aggregate policers are used when policing traffic across multiple class maps, policy maps or
ports. You create them in global configuration mode and then attach them to the required
class maps. They are identified by a name.
The following commands give an example of a single-rate aggregate policer that has a CIR of
1
0Mbps with a CBS of 5
1
2 bytes and PBS of
1
024 bytes. The aggregator policer operates on
any traffic arriving on ports
1
.0.
1
and
1
.0.2 with a source address of
1
92.
1
68.x.x or
1
72.20.
1
.x.
awplus(config)#access-list 3001 permit ip 192.168.0.0/16 any
awplus(config)#access-list 3002 permit ip 172.20.1.0/24 any
awplus(config)#mls qos aggregate-police examplePolicer
single-rate 10 512 1024 exceed-action drop
awplus(config)#class-map cmap1
awplus(config-cmap)#match access-group 3001
awplus(config)#class-map cmap2
awplus(config-cmap)#match access-group 3002
awplus(config)#policy-map pmap1
awplus(config-pmap)#class cmap1
awplus(config-pmap-c)#police aggregate examplePolicer
awplus(config-pmap)#class cmap2
awplus(config-pmap-c)#police aggregate examplePolicer
awplus(config)#interface port1.0.1-1.0.2
awplus(config-if)#service-policy input pmap1
To see the settings of aggregate policers, use the command:
awplus#show mls qos aggregate-policer