Lucent Technologies P550 Switch User Manual


 
Configuring OSPF
1-10 Command Line Interface Protocol Configuration Guide
This example enables OSPF and redistributes RIP into OSPF and OSPF into RIP.
Cajun (configure)#
router ospf
Cajun (configure router:ospf)#
network 120.1.2.2 0.0.255.255 area 0.0.0.0
Cajun
(configure router:ospf)#
exit
Cajun
(configure)#
router rip
Cajun (configure router:rip)# network 120.2.2.2
This example enables OSPF routing, defines three OSPF areas (0.0.0.1, 0.0.0.2, and
0.0.0.3), masks specific address ranges within areas 0.0.0.1 and 0.0.0.2, and enables
OSPF for all other networks using area 0.0.0.3.
Cajun (configure)#
router ospf
Cajun
(configure router:ospf)#
network 111.1.5.3. 0.0.0.255 area 0.0.0.1
Cajun (configure router:ospf)#
network 121.9.5.0 0.0.0.255 area 0.0.0.2
Cajun (configure router:ospf)#
network 0.0.0.0 255.255.255.255 area 0.0.0.3
Cajun
(configure router:ospf)#
exit
!
!
Interface testospf1 is in area 0.0.0.1
Cajun (configure)#
interface testospf1
Cajun
(config-if:testospf1)#
ip address 111.1.5.20 255.255.255.0
Cajun
(config-if:testospf1)#
exit
!
!
Interface testospf2 is in area 0.0.0.2
Cajun (configure)#
interface testospf2
Cajun
(config-if:testospf2)#
ip address 121.9.5.8 255.255.255.0
Cajun
(config-if:testospf2)#
exit
!
!
Interface testospf3 is in area 0.0.0.3
Cajun (configure)#
interface testospf3
Cajun
(config-if:testospf3)#
ip address 121.19.0.0 255.255.255.0
Cajun
(config-if:testospf3)#
exit
!
!
This saves the configuration.
Cajun (configure)#
copy running-config startup-config
In this example, route summarization occurs in both directions between areas 0.0.0.1
and 0.0.0.0. This is achieved by masking the first three left-most bits of the subnet using
mask 255.255.224.0.
Cajun (configure)#
router ospf
Cajun (configure router:ospf)#
network 172.11.6.2 0.0.0.0 area 0.0.0.1
Cajun (configure router:ospf)#
network 152.11.33.5 0.0.0.0 area 0.0.0.0
Cajun (configure router:ospf)#
area 0.0.0.0 range 172.4.4.2 255.255.224.0
Cajun (configure router:ospf)#
area 0.0.0.1 range 172.4.2.1 255.255.224.0
Cajun (configure router:ospf)#
exit
!
!
This saves the configuration.
Cajun (configure)#
copy running-config startup-config