Cisco Systems 2600 Computer Accessories User Manual


 
Cisco Hoot and Holler over IP
Configuration Examples
26
Cisco IOS Release 12.1(5)T
broadcast-queue is only 40 packets deep and Cisco Hoot and Holler over IP transmits packets at 50
packets per second. Unless the queue is disabled, some packets would be dropped and voice QoS would
be degraded.
Router-1
hostname Router-1
!
ip multicast-routing
!
voice class permanent 1
signal timing oos timeout disabled
signal keepalive 65535
!
interface Vif1
ip address 1.1.1.1 255.255.255.0
ip pim sparse-dense-mode
!
router rip
network 1.1.1.0
network 5.5.5.0
network 5.5.6.0
!
interface Serial0/0
no ip address
ip pim sparse-dense-mode
encapsulation frame-relay
frame-relay traffic-shaping
no frame-relay broadcast-queue
!
interface Serial0/0.1 point-to-point
ip address 5.5.5.1 255.255.255.0
ip pim sparse-dense-mode
frame-relay class hoot-n-holler
frame-relay interface-dlci 100
frame-relay ip rtp header-compression
!
interface Serial0/0.2 point-to-point
ip address 5.5.6.1 255.255.255.0
ip pim sparse-dense-mode
frame-relay class hoot-n-holler
frame-relay interface-dlci 101
frame-relay ip rtp header-compression
!
map-class frame-relay hoot-n-holler
frame-relay cir 128000
frame-relay bc 1280
frame-relay mincir 128000
frame-relay fragment 160
frame-relay ip rtp priority 16384 16384 128
no frame-relay adaptive-shaping
!
voice-port 1/0/0
voice-class permanent 1
connection trunk 111
music-threshold -30
operation 4-wire
!
dial-peer voice 1 voip
destination-pattern 111
session protocol multicast
session target ipv4:237.111.0.0:22222