Allied Telesis C613-16164-00 REV E Network Card User Manual


 
Configure VRF-lite | Page 81
Dynamic inter-VRF routing between the global VRF domain and a VRF instance
Dynamic inter-VRF communication with i-BGP routing to
external peer
VRF device
access-list standard redblock4445 deny 192.168.44.0/24
access-list standard redblock4445 deny 192.168.45.0/24
access-list standard redblock4445 permit any
!
ip vrf red 1
rd 100:1
!
vlan database
vlan 10 state enable
!
interface port1.0.3
switchport access vlan 10
!
interface lo
ip address 1.1.1.1/32
!
interface lo1
ip address 2.2.2.2/32
!
interface vlan1
ip address 192.168.50.1/24
!
interface vlan10
ip vrf forwarding red
ip address 192.168.10.1/24
!
router bgp 100
redistribute connected
redistribute static
neighbor 2.2.2.2 remote-as 64512 vrf red
neighbor 2.2.2.2 local-as 64515
neighbor 2.2.2.2 update-source 1.1.1.1
neighbor 2.2.2.2 route-map 43 out
!
address-family ipv4 vrf red
redistribute connected
redistribute static
neighbor 1.1.1.1 remote-as 64515 global
neighbor 1.1.1.1 local-as 64512
neighbor 1.1.1.1 update-source lo1
neighbor 1.1.1.1 activate
neighbor 7.7.7.7 remote-as 100
neighbor 7.7.7.7 update-source lo1
neighbor 7.7.7.7 activate
neighbor 7.7.7.7 next-hop-self
exit-address-family
!
ip route 2.2.2.2/32 lo1
ip route 192.168.43.0/24 192.168.50.2
ip route 192.168.44.0/24 192.168.50.2
ip route 192.168.45.0/24 192.168.50.2
ip route vrf red 1.1.1.1/32 lo
ip route vrf red 7.7.7.7/32 192.168.10.2
!
route-map 43 permit 1
match ip address redblock4445