Cisco Systems OL-14356-01 Network Router User Manual


 
Implementing EIGRP on Cisco IOS XR Software
Configuration Examples for Implementing EIGRP on Cisco IOS XR Software
RC-167
Cisco IOS XR Routing Configuration Guide
OL-14356-01
interface POS0/2/0/0
passive-interface
!
interface GigabitEthernet0/6/0/0
hello-interval 8
hold-time 30
summary-address 10.0.0.0 255.255.0.0
!
!
!
Configuring an EIGRP Stub Operation: Example
The following example shows how to configure an EIGRP stub. Stub operation allows only connected,
static, and summary routes to be advertised to neighbors.
router eigrp 200
address-family ipv4
stub connected static summary
router-id 172.16.82.22
log-neighbor-changes
log-neighbor-warnings
redistribute connected route-policy CONN_POLICY
interface GigabitEthernet0/6/0/0
passive-interface
neighbor 10.0.0.31
!
interface GigabitEthernet0/6/0/1
passive-interface
neighbor 10.0.1.21
!
!
!
Configuring an EIGRP PE-CE Configuration with Prefix-Limits: Example
The following example shows how to configure EIGRP to operate as a PE-CE protocol on a PE router.
The configuration is under VRF CUSTOMER_1. A maximum prefix is typically configured to ensure
that one set of customer routes do not overwhelm the EIGRP process.
router eigrp 500
vrf CUSTOMER_1
address-family ipv4
timers nsf route-hold 300
router-id 172.16.6.11
maximum-prefix 450 70
default-metric 200000 10000 195 10 1500
log-neighbor-changes
log-neighbor-warnings
redistribute maximum-prefix 350 70
redistribute bgp 1.65500 route-policy SITE_1_POLICY
interface POS0/4/0/5
neighbor 10.22.1.1
!
!
!