Cisco Systems OL-14356-01 Network Router User Manual


 
Implementing OSPF on Cisco IOS XR Software
Configuration Examples for Implementing OSPF on Cisco IOS XR Software
RC-261
Cisco IOS XR Routing Configuration Guide
OL-14356-01
!
interface GigabitEthernet0/2/0/2
vrf vrf_1
ipv4 address 100.10.10.2 255.255.255.0
!
interface GigabitEthernet0/2/0/3
ipv4 address 100.20.10.2 255.255.255.0
!
!
route-policy pass-all
pass
end-policy
!
router ospf 1
log adjacency changes
router-id 2.2.2.2
vrf vrf_1
router-id 22.22.22.2
domain-id type 0005 value 111122223333
domain-tag 140
nsf ietf
redistribute bgp 10
area 0
sham-link 10.0.1.3 10.0.0.101
!
interface GigabitEthernet0/2/0/2
!
!
!
!
router ospf 2
router-id 2.22.2.22
area 0
interface Loopback0
!
interface GigabitEthernet0/2/0/3
!
!
!
router bgp 10
bgp router-id 2.2.2.1
bgp graceful-restart restart-time 300
bgp graceful-restart
address-family ipv4 unicast
redistribute connected
!
address-family vpnv4 unicast
!
neighbor 2.2.2.2
remote-as 10
update-source Loopback0
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
!
vrf vrf_1
rd 100:1
address-family ipv4 unicast
redistribute connected route-policy pass-all
redistribute ospf 1 match internal external
!
!
!