Cisco Systems 10000 Network Router User Manual


 
23-15
Cisco 10000 Series Router Software Configuration Guide
OL-2226-23
Chapter 23 Configuring Gigabit EtherChannel Features
Configuring VLAN-Based Load Balancing
Example 23-5 Configuring The VLAN-Based Load Balancing Feature
configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
interface port-channel 1
load-balancing vlan
lacp max-bundle 2
exit
!
interface gigabitethernet2/1/0
no ip address
channel-group 1 mode active
exit
!
interface gigabitethernet8/0/0
no ip address
channel-group 1 mode active
exit
!
interface port-channel 1.1
encapsulation dot1q 2 primary gigabitethernet2/1/0 secondary gigabitethernet8/0/0
ip address 3.0.0.1 255.255.255.0
no sh
Configuration Example for Applying VLAN QoS on GEC Bundle Subinterfaces
Example 23-6 shows how VLAN QoS is applied on GEC bundle subinterfaces:
Example 23-6 Applying VLAN QoS on GEC Bundle Subinterfaces
Class-map match-any dscp_20_30
Match dscp 20 30
Class-map match-any dscp_40
Match dscp 40
Policy-map police_dscp
Class dscp_20_30
Police 50 3000 3000 conform-action transmit exceed-action drop
Set ip dscp af22
Class dscp_40
Police 10 3000 3000 conform-action transmit exceed-action drop
Policy-map customer_A
Class class-default
Police 100 mpbs
service-policy police_dscp
Policy-map customer_B
Class class-default
Police 150 mbps
Service-policy police_dscp
Interface Port-channel 1.1
Service-policy input customer_A
encapsulation dot1q 1 primary gigabitethernet2/1/0 secondary gigabitethernet8/0/0
Interface Port-channel 1.2
Service-policy input customer_B