Cisco Systems 1000 Series Network Router User Manual


 
16-52
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 16 Configuring MPLS Layer 2 VPNs
Configuring HDLC-Ethernet Interworking
The following example shows how to configure the HDLC-Ethernet interworking on the Controller slot
on Ethernet PE:
controller E1 0/1/0
channel-group 0 timeslots 1
no shutdown
interface Serial0/1/0:0
no shutdown
The following example shows how to configure the HDLC-Ethernet interworking using legacy CLI.
The following example shows how to configure on HDLC-CE and HDLC-PE in Bridged (Ethernet)
mode using legacy CLI:
On HDLC-CE
configure terminal
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
int BVI1
ip address 192.168.1.1 255.255.255.0
no shut
!
interface Serial2/0:0
description Connect to PE1
encapsulation hdlc
bridge-group 1
no shut
end
HDLC-PE:
configure terminal
pseudowire-class pw-iw-eth
encapsulation mpls
interworking Ethernet
!
interface Serial0/1/0:0
description Connect to CE1
encapsulation hdlc
no ip address
xconnect 3.3.3.3 100 pw-class pw-iw-eth
no shut
end
The following example shows how to configure Ethernet on Ethernet-CE and Ethernet-PE in Bridged
(Ethernet) mode using legacy CLI:
On Ethernet-CE
configure terminal
interface GigabitEthernet0/1
description Connect to PE2
ip address 192.168.1.2 255.255.255.0
ip irdp
ip irdp maxadvertinterval 4
no shut
end
On Ethernet-PE
configure terminal
pseudowire-class pw-iw-eth