Cisco Systems 1000 Series Network Router User Manual


 
16-54
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 16 Configuring MPLS Layer 2 VPNs
Configuring HDLC-Ethernet Interworking
end
On Ethernet-PE:
configure terminal
pseudowire-class pw-iw-eth
encapsulation mpls
interworking Ethernet
!
interface GigabitEthernet1/0/0
no ip address
no shut
!
interface GigabitEthernet1/0/0.10
description Connect to CE2
encapsulation dot1Q 10 second-dot1q 20
no ip address
xconnect 1.1.1.1 100 pw-class pw-iw-eth
no shut
end
The following example shows how to configure HDLC-Ethernet interworking using Protocol-Based
CLI:
The following example shows how to configure HDLC on HDLC-CE and HDLC-PE in Bridged
(Ethernet) mode using protocol-based CLI:
On HDLC-CE:
configure terminal
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
int BVI1
ip address 192.168.1.1 255.255.255.0
no shut
!
interface Serial2/0:0
description Connect to PE1
encapsulation hdlc
bridge-group 1
no shut
end
On HDLC-PE:
configure terminal
interface Serial0/1/0:0
description Connect to CE1
encapsulation hdlc
no ip addres
no shut
!
Interface pseudowire101
encapsulation mpls
neighbor 3.3.3.3 100
signaling protocol ldp
no shut
l2vpn xconnect context foohdlc
interworking ethernet
member Serial0/1/0:0
member pseudowire101
no shut