Cisco Systems 1000 Series Network Router User Manual


 
16-55
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 16 Configuring MPLS Layer 2 VPNs
Configuring HDLC-Ethernet Interworking
end
The following example shows how to configure Ethernet on Ethernet-CE and Ethernet-PE - Bridged
(Ethernet) mode using protocol-based CLI:
On Ethernet-CE:
configure terminal
interface GigabitEthernet0/1
description Connect to PE2
ip address 192.168.1.2 255.255.255.0
ip irdp
ip irdp maxadvertinterval 4
no shut
end
On Ethernet-PE:
configure terminal
interface GigabitEthernet1/0/0
description Connect to CE2
no ip address
no shut
!
Interface pseudowire101
encapsulation mpls
neighbor 1.1.1.1 100
signaling protocol ldp
no shut
!
l2vpn xconnect context fooeth
interworking ethernet
member GigabitEthernet1/0/0
member pseudowire101
no shut
end
The following example shows how to configure VLAN on Ether-CE and Ethernet-PE in Bridged
(Ethernet) mode using protocol-based CLI:
On Ethernet-CE:
configure terminal
!
interface GigabitEthernet0/1
no ip address
no shut
!
interface GigabitEthernet0/1.10
encapsulation dot1q 10
description Connect to PE2
ip address 192.168.1.2 255.255.255.0
ip irdp
ip irdp maxadvertinterval 4
no shut
end
On Ethernet-PE:
configure terminal
!
interface GigabitEthernet1/0/0
no ip address
no shut
!