Cisco Systems 1000 Series Network Router User Manual


 
18-52
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 18 LSM-MLDP-based MVPN Support
mdt default mpls MLDP 4.4.4.4
mdt data mpls MLDP 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family