Cisco Systems 1000 Series Network Router User Manual


 
18-72
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 18 LSM-MLDP-based MVPN Support
MVPN MLDP over GRE
Router(config)# interface GigabitEthernet 0/0/0
Router(config-if)# ip address 10.0.0.21 255.255.255.0
Router(config-if)# exit
Router(config)# interface Tunnel 100
Router(config-if)# ip address 10.0.0.1 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# tunnel source 10.0.0.21
Router(config-if)# tunnel destination 10.0.0.22
Router(config-if)# exit
Router(config-if)# end
The following example shows how to configure MVPNv4 MLDP over GRE on router PE2:
Router# enable
Router# configure terminal
Router(config)# vrf definition VRF_blue
Router(config-vrf)# rd 1:1
Router(config-vrf)# vpn id 1:1
Router(config-vrf)# address-family ipv4
Router(config-vrf-af)# mdt default mpls mldp 1.1.1.1
Router(config-vrf-af)# mdt data mpls mldp 100
Router(config-vrf-af)# mdt data threshold 1000
Router(config-vrf-af)# route-target export 1:1
Router(config-vrf-af)# route-target import 1:1
Router(config-vrf-af)# exit
Router(config-vrf)# exit
Router(config)# ip multicast-routing vrf blue distributed
Router(config)# interface Loopback 0
Router(config-if)# ip address 2.2.2.2 255.255.255.0
Router(config-if)# exit
Router(config)# interface Loopback 1
Router(config-if)# vrf forwarding blue
Router(config-if)# ip address 192.0.100.20 255.255.255.0
Router(config-if)# ip pim sparse-mode
Router(config-if)# exit
Router(config)# interface GigabitEthernet 0/0/0
Router(config-if)# ip address 10.0.0.22 255.255.255.0
Router(config-if)# exit
Router(config)# interface Tunnel 100
Router(config-if)# ip address 10.0.0.5 255.255.255.0
Router(config-if)# mpls ip
Router(config-if)# tunnel source 10.0.0.22
Router(config-if)# tunnel destination 10.0.0.21
Router(config-if)# exit
Router(config-if)# end
To display the IPv6 neighbor information, use the show ipv6 pim vrf vrf-name neighbor command:
Router# show ipv6 pim vrf vrf blue neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, G - GenID Capable
Neighbor Address Interface Uptime Expires Mode DR pri
::FFFF:1.1.1.1 Lspvif 3w0d 00:01:17 B G 1
Here, 1.1.1.1 is the loopback IP address of another PE on the other end of GRE tunnel, and
::FFFF:x.x.x.x is IPv4-mapped IPv6 IP address.