Cisco Systems 1000 Series Network Router User Manual


 
18-51
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 18 LSM-MLDP-based MVPN Support
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 101.3.0.2
MLDP MVPN Extranet RSC
Configuration on PE1 Router (Source PE)
ip vrf red2
rd 10:2
vpn id 10:2