Cisco Systems 1000 Series Network Router User Manual


 
18-44
Cisco ASR 1000 Series Aggregation Services Routers Software Configuration Guide
OL-16506-17
Chapter 18 LSM-MLDP-based MVPN Support
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 102.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static